0712-2888027 189-8648-0214
                                                                                    微信公眾號

                                                                                    孝感風信網絡科技有限公司微信公眾號

                                                                                    當前位置:主頁 > 技術支持 > PHP > CentOS解決cannot install both libpcap-14:1.9.1-5.el8.x86_64 and libpcap-14:1.9.1-4.el8.x86_64的方法

                                                                                    CentOS解決cannot install both libpcap-14:1.9.1-5.el8.x86_64 and libpcap-14:1.9.1-4.el8.x86_64的方法

                                                                                    時間:2024-06-02來源:風信官網 點擊: 5322次

                                                                                    維護更新CentOS 8 Linux系統運行命令報錯如下:

                                                                                    [root@iZwz92jeancylpcm6qlws1Z yum.repos.d]# yum upgrade


                                                                                    Repository extras is listed more than once in the configuration
                                                                                    Repository epel is listed more than once in the configuration
                                                                                    Last metadata expiration check: 0:00:14 ago on Thu 28 Oct 2021 02:02:47 PM CST.
                                                                                    Error:
                                                                                    Problem: cannot install both libpcap-14:1.9.1-5.el8.x86_64 and libpcap-14:1.9.1-4.el8.x86_64
                                                                                    - package libpcap-devel-14:1.9.1-4.el8.x86_64 requires libpcap = 14:1.9.1-4.el8, but none of the providers can be installed
                                                                                    - cannot install the best update candidate for package libpcap-14:1.9.1-4.el8.x86_64
                                                                                    - problem with installed package libpcap-devel-14:1.9.1-4.el8.x86_64
                                                                                    (try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

                                                                                    出現上述--skip-broken的原因并不在于緩存問題,而是libpcap軟件包沒有卸載完導致,我們可以通過查詢相關的rpm包刪除干凈,再進行系統的更新。

                                                                                    [root@iZwz92jeancylpcm6qlws1Z yum.repos.d]# rpm -qa | grep libpcap |xargs rpm -e --nodeps

                                                                                    現在可以使用yum upgrade命令更新系統啦,風信網絡建站專業的技術服務為您提供互聯網全技術棧的解決方案,針對一套管理后臺,可同時管理PC端、移動端、APP端、各種小程序端互聯網應用,實現多端跨平臺運行,服務熱線:189-8648-0214。

                                                                                    熱門關鍵詞: CentOS libpcap
                                                                                    欄目列表
                                                                                    推薦內容
                                                                                    熱點內容
                                                                                    展開
                                                                                    亚洲AV秘 无码不卡一区二区,天天一本大道久久,亚洲污视频在线观看,97超碰国产精品无码